SBCC Help Center (Jira) Outage
Incident Report for SBCC IT
Resolved
Access has been restored for the SBCC Help Center.
Posted Sep 06, 2024 - 11:50 PDT
Investigating
We are currently aware of the outage with our SBCC Help Center (IT/Fiscal tickets), and are looking into the cause. We hope to have this back up as soon as possible.
Posted Sep 06, 2024 - 11:35 PDT
This incident affected: SBCC Help Center (Jira).