Banner Self - Service Finance Access Issues
Incident Report for SBCC IT
Resolved
The Banner Self-Service Finance access issues have been resolved. Please reach out to our IT Support Desk if you are still having issues access Banner Self-Service Finance. The contact information for our IT Support Desk can be found at: https://www.sbcc.edu/it/helpdesk.php
Posted Sep 12, 2024 - 14:26 PDT
Investigating
Multiple users are reporting that Banner self-service finance is not available. We are investigating.
Posted Sep 11, 2024 - 10:41 PDT
This incident affected: Banner (Banner PROD).