Password Reset Processing Delay

Incident Report for SBCC IT

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 15:04 PDT

Investigating

Password resets are currently experiencing a delay in processing time. Technicians are investigating this issue. Unfortunately, we anticipate that our team will have to continue working on this into the weekend or Monday morning to resolve the issue. If you have already attempted to reset your password and it is not working, or you are planning to reset your password, please wait until Monday. Additionally, please refer to the SBCC IT Status page located at https://status.sbcc.edu for more information. Thank you for your patience and understanding!
Posted Apr 18, 2025 - 11:42 PDT
This incident affected: Single Sign On Login.